Skip to content

Problems with bundle install using Ruby On Rails

March 17, 2013

If you are using RubyInstaller on Windows, you may encounter a problem with the command bundle install, if you are using inside your gems file, the following: –

# Use unicorn as the app server
gem ‘unicorn’

It would lead to an error called Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options.

on the install kgio.

The kgio gem only builds and runs on Unix like systems (http://bogomips.org/kgio/) It uses functions which are not natively available on Windows.

You have to install another app server program called ‘thin’ s if you are trying to use Unicorn, then you just need to replace the webserver.

Give Thin a try. Add the following lines to your Gemfile:

gem 'thin
Advertisements

From → Uncategorized

Leave a Comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: